Advanced Custom Fields <= 3.5.1 - Remote Code Execution via Remote File Inclusion

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')
CVSS 3.8 (Low)
Publicly Published January 3, 2013
Last Updated January 18, 2023


Advanced Custom Fields up to 3.5.1 is vulnerable to Remote Code Execution. The vulnerability allows for remote file inclusion and remote code execution via the export.php script. This exploit only works when the php option allow_url_include is set to On (Default Off).



1 affected software package

Software Type Plugin
Software Slug advanced-custom-fields (view on
Patched? Yes
Remediation Update to version 3.5.2, or a newer patched version
Affected Version
  • <= 3.5.1
Patched Version
  • 3.5.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.