Ajax Search Lite < 3.11 - Missing Authorization to Remote Code Execution

Missing Authorization
CVSS 8.8 (High)
Publicly Published March 26, 2015
Last Updated January 6, 2023
Researcher Evex - Evex


The Ajax Search Lite plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the wpdreams_ajaxinputcallback function in versions up to, and including, 3.10. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to bypass restricted actions, which can lead to remote code execution.



Vulnerability Details for Ajax Search Lite

Software Type Plugin
Software Slug ajax-search-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.11, or a newer patched version
Affected Version
  • < 3.11
Patched Version
  • 3.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.