Ajax Search Lite <= 4.10.3 - Missing Authorization leading to Authenticated (Subscriber+) Sensitive Information Disclosure

Missing Authorization
CVE CVE-2022-38456
CVSS 4.3 (Medium)
Publicly Published February 6, 2023
Last Updated February 16, 2023
Researcher István Márton - Wordfence


The Ajax Search Lite plugin for WordPress is vulnerable to Missing Authorization (leading to Sensitive Information Disclosure) in versions up to, and including, 4.10.3 via the 'searchCF' function. This can allow subscriber-level attackers to extract sensitive data including post metadata from an unprotected Ajax endpoint.



Vulnerability Details for Ajax Search Lite

Software Type Plugin
Software Slug ajax-search-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.11, or a newer patched version
Affected Version
  • <= 4.10.3
Patched Version
  • 4.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.