Backup Migration <= 1.3.9 - Unauthenticated Path Traversal to Arbitrary File Deletion

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-6972
CVSS 9.8 (Critical)
Publicly Published December 22, 2023
Last Updated April 15, 2024
Researcher Hiroho Shimada


The Backup Migration plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.3.9 via the 'content-backups' and 'content-name', 'content-manifest', or 'content-bmitmp' and 'content-identy' HTTP headers. This makes it possible for unauthenticated attackers to delete arbitrary files, including the wp-config.php file, which can make site takeover and remote code execution possible.



Vulnerability Details for Backup Migration

Software Type Plugin
Software Slug backup-backup (view on
Patched? Yes
Remediation Update to version 1.4.0, or a newer patched version
Affected Version
  • <= 1.3.9
Patched Version
  • 1.4.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.