Bold Page Builder <= 2.3.1 - Missing Authorization to Settings Update

Missing Authorization
CVE CVE-2019-15821
CVSS 7.5 (High)
Publicly Published August 23, 2019
Last Updated January 19, 2023
Researcher Jerome Bruandet - NinTechNet


The bold-page-builder plugin before 2.3.2 for WordPress has no protection against modifying settings and importing data.



Vulnerability Details for Bold Page Builder

Software Type Plugin
Software Slug bold-page-builder (view on
Patched? Yes
Remediation Update to version 2.3.2, or a newer patched version
Affected Version
  • <= 2.3.1
Patched Version
  • 2.3.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.