BookingPress <= 1.0.30 - Unauthenticated Insecure Direct Object Reference

6.5
Authorization Bypass Through User-Controlled Key
CVE CVE-2022-4340
CVSS 6.5 (Medium)
Publicly Published December 7, 2022
Last Updated January 13, 2023
Researcher Hussien Misbah

Description

The BookingPress plugin for WordPress is vulnerable to insecure direct object reference in versions up to, and including, 1.0.30. This is due to insufficient validation on the 'appointment_id' user-controlled key. This makes it possible for unauthenticated attackers to retrieve booking information that includes booked services along with the name and time of booking.

References

Share

Vulnerability Details for Appointment Booking Calendar Plugin and Online Scheduling Plugin – BookingPress

Software Type Plugin
Software Slug bookingpress-appointment-booking (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.31, or a newer patched version
Affected Version
  • <= 1.0.30
Patched Version
  • 1.0.31

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation