AI ChatBot <= 4.8.9 and 4.9.2- Authenticated (Subscriber+) Arbitrary File Deletion via qcld_openai_delete_training_file

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-5212
CVSS 9.6 (Critical)
Publicly Published October 11, 2023
Last Updated October 23, 2023
Researchers Marco Wotschka - Wordfence
Chloe Chamberland - Wordfence


The AI ChatBot plugin for WordPress is vulnerable to Arbitrary File Deletion in versions up to, and including, 4.8.9 as well as version 4.9.2. This makes it possible for authenticated attackers with subscriber privileges to delete arbitrary files on the server, which makes it possible to take over affected sites as well as others sharing the same hosting account. Version 4.9.1 originally addressed the issue, but it was reintroduced in 4.9.2 and fixed again in 4.9.3.



1 affected software package

Software Type Plugin
Software Slug chatbot (view on
Patched? Yes
Remediation Update to one of the following versions, or a newer patched version: 4.9.1, 4.9.3
Affected Versions
  • 4.9.2 - 4.9.2
  • <= 4.8.9
Patched Versions
  • 4.9.1
  • 4.9.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.