AI ChatBot <= 4.8.9 - Unauthenticated Sensitive Information Exposure via qcld_wb_chatbot_check_user

Information Exposure
CVE CVE-2023-5254
CVSS 5.3 (Medium)
Publicly Published October 11, 2023
Last Updated January 22, 2024
Researcher Marco Wotschka - Wordfence


The ChatBot plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 4.8.9 via the qcld_wb_chatbot_check_user function. This can allow unauthenticated attackers to extract sensitive data including confirmation as to whether a user name exists on the site as well as order information for existing users.



Vulnerability Details for AI ChatBot for WordPress – WPBot

Software Type Plugin
Software Slug chatbot (view on
Patched? Yes
Remediation Update to version 4.9.1, or a newer patched version
Affected Version
  • <= 4.8.9
Patched Version
  • 4.9.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.