Cookies and Content Security Policy <= 2.15 - Sensitive Information Exposure

Information Exposure
CVE CVE-2023-40662
CVSS 5.3 (Medium)
Publicly Published August 18, 2023
Last Updated August 21, 2023
Researcher Mika


The Cookies and Content Security Policy plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 2.15 via the cacsp_texts function. This can allow unauthenticated attackers to extract sensitive data including the administrator email address.



1 affected software package

Software Type Plugin
Software Slug cookies-and-content-security-policy (view on
Patched? Yes
Remediation Update to version 2.16, or a newer patched version
Affected Version
  • <= 2.15
Patched Version
  • 2.16

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.