Elementor Pro <= 3.11.6 - Authenticated(Subscriber+) Privilege Escalation via update_page_option

Missing Authorization
CVE CVE-2023-3124
CVSS 8.8 (High)
Publicly Published March 28, 2023
Last Updated June 7, 2023
Researcher Jerome Bruandet - NinTechNet


The Elementor Pro plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the update_page_option function in versions up to, and including, 3.11.6. This makes it possible for authenticated attackers with subscriber-level capabilities to update arbitrary site options, which can lead to privilege escalation.



Vulnerability Details for Elementor Website Builder Pro

Software Type Plugin
Software Slug elementor-pro
Patched? Yes
Remediation Update to version 3.11.7, or a newer patched version
Affected Version
  • <= 3.11.6
Patched Version
  • 3.11.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.