FeedWordPress <= 2022.0222 - Insecure Direct Object Referece

Authorization Bypass Through User-Controlled Key
CVE CVE-2024-0839
CVSS 5.3 (Medium)
Publicly Published March 4, 2024
Last Updated May 13, 2024
Researcher Krzysztof Zając - CERT PL


The FeedWordPress plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2022.0222 due to missing validation on the user controlled 'guid' key. This makes it possible for unauthenticated attackers to view draft posts that may contain sensitive information.



Vulnerability Details for FeedWordPress

Software Type Plugin
Software Slug feedwordpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 2024.0428, or a newer patched version
Affected Version
  • <= 2022.0222
Patched Version
  • 2024.0428

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.