Formidable Form Builder < 2.05.03 - Reflected Cross-Site Scripting

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 6.1 (Medium)
Publicly Published November 13, 2017
Last Updated January 22, 2024
Researcher Jouko Pynnöne

Description

The Formidable Form Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'before_html' parameter passed through the frm_forms_preview AJAX action in versions before 2.05.03 due to insufficient input sanitization and output escaping. This makes it possible for attackers to inject arbitrary web scripts that execute in a victim's browser whenever they successfully trick a victim into performing an action like clicking on a link.

Wordfence blocked 81 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for Formidable Forms – Contact Form Plugin, Survey, Quiz, Payment, Calculator Form & Custom Form Builder

Software Type Plugin
Software Slug formidable (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.05.03, or a newer patched version
Affected Version
  • < 2.05.03
Patched Version
  • 2.05.03

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation