GiveWP <= 2.25.2 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published March 23, 2023
Last Updated March 24, 2023


The GiveWP for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.25.2. This is due to missing or incorrect nonce validation on the give_donation_import_callback function. This makes it possible for unauthenticated attackers to process the import of donations via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for GiveWP – Donation Plugin and Fundraising Platform

Software Type Plugin
Software Slug give (view on
Patched? Yes
Remediation Update to version 2.25.3, or a newer patched version
Affected Version
  • <= 2.25.2
Patched Version
  • 2.25.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.