Site Kit by Google <= 1.7.1 - Sensitive Information Disclosure

Information Exposure
CVE CVE-2020-8934
CVSS 4.3 (Medium)
Publicly Published May 21, 2020
Last Updated January 22, 2024
Researcher Chloe Chamberland - Wordfence


The Site Kit by Google plugin for WordPress is vulnerable to Sensitive Information Disclosure in versions up to, and including, 1.7.1. This is due to the lack of capability checks on the admin_enqueue_scripts action which displays the connection key. This makes it possible for authenticated attackers with any level of access obtaining owner access to a site in the Google Search Console.



1 affected software package

Software Type Plugin
Software Slug google-site-kit (view on
Patched? Yes
Remediation Update to version 1.8.0, or a newer patched version
Affected Version
  • <= 1.7.1
Patched Version
  • 1.8.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.