OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy. <= 5.7.9 - Missing Authorization to Unauthenticated Directory Deletion and Cross-Site Scripting

8.6
Missing Authorization
CVE CVE-2023-6600
CVSS 8.6 (High)
Publicly Published January 2, 2024
Last Updated January 22, 2024
Researcher Lucio Sá

Description

The OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy. plugin for WordPress is vulnerable to unauthorized modification of data and Stored Cross-Site Scripting due to a missing capability check on the update_settings() function hooked via admin_init in all versions up to, and including, 5.7.9. This makes it possible for unauthenticated attackers to update the plugin's settings which can be used to inject Cross-Site Scripting payloads and delete entire directories. PLease note there were several attempted patched, and we consider 5.7.10 to be the most sufficiently patched.

Wordfence blocked 4 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy.

Software Type Plugin
Software Slug host-webfonts-local (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.7.10, or a newer patched version
Affected Version
  • <= 5.7.9
Patched Version
  • 5.7.10

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation