Icegram Engage <= 2.1.7 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1776
CVSS 6.1 (Medium)
Publicly Published May 30, 2022
Last Updated January 22, 2024
Researcher Pritam Dash


The Popups, Welcome Bar, Optins and Lead Generation Plugin WordPress plugin before 2.1.8 does not sanitize and escape some campaign parameters, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks



Vulnerability Details for Icegram Engage – Ultimate WP Popup Builder, Lead Generation, Optins, and CTA

Software Type Plugin
Software Slug icegram (view on
Patched? Yes
Remediation Update to version 2.1.8, or a newer patched version
Affected Version
  • < 2.1.8
Patched Version
  • 2.1.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.