KB Support <= 1.5.88 - Missing Authorization to Sensitive Data Exposure

Missing Authorization
CVE CVE-2023-37890
CVSS 5.4 (Medium)
Publicly Published July 11, 2023
Last Updated July 14, 2023
Researcher Rafshanzani Suhada


The KB Support plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 1.5.88 via the kbs_ajax_get_customer_data function due to lack of a capability check. This can allow authenticated attackers with subscriber access or higher to extract sensitive data including customer data including name, email, phone number.



1 affected software package

Software Type Plugin
Software Slug kb-support (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.5.89, or a newer patched version
Affected Version
  • <= 1.5.88
Patched Version
  • 1.5.89

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.