Masteriyo - LMS for WordPress <= 1.6.7 - Sensitive Information Exposure

Information Exposure
CVE CVE-2023-3345
CVSS 6.5 (Medium)
Publicly Published July 3, 2023
Last Updated July 11, 2023
Researcher Yassir Sbai Fahim (iduzzel)


The Masteriyo - LMS for WordPress plugin is vulnerable to Sensitive Information Exposure in versions up to, and including, 1.6.7 via the 'get_item' REST callback. This can allow authenticated attackers to extract sensitive data including user metadata.



1 affected software package

Software Type Plugin
Software Slug learning-management-system (view on
Patched? Yes
Remediation Update to version 1.6.8, or a newer patched version
Affected Version
  • < 1.6.8
Patched Version
  • 1.6.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.