My Sticky Bar <= 2.6.6 - Cross-Site Request Forgery to Sensitive Information Exposure

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-7048
CVSS 3.1 (Low)
Publicly Published January 3, 2024
Last Updated January 22, 2024
Researcher Ulyses Saicha


The My Sticky Bar plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.6. This is due to missing or incorrect nonce validation in mystickymenu-contact-leads.php. This makes it possible for unauthenticated attackers to trigger the export of a CSV file containing contact leads via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Because the CSV file is exported to a public location, it can be downloaded during a very short window of time before it is automatically deleted by the export function.



Vulnerability Details for Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme – My Sticky Bar (formerly myStickymenu)

Software Type Plugin
Software Slug mystickymenu (view on
Patched? Yes
Remediation Update to version 2.6.7, or a newer patched version
Affected Version
  • <= 2.6.6
Patched Version
  • 2.6.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.