Poll Maker – Best WordPress Poll Plugin <= 5.1.8 - Missing Authorization to Unauthenticated Stored Cross-Site Scripting

Missing Authorization
CVE CVE-2024-3600
CVSS 7.2 (High)
Publicly Published April 18, 2024
Last Updated April 19, 2024
Researcher Krzysztof Zając - CERT PL


The Poll Maker – Best WordPress Poll Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting due to a missing capability check on the ays_poll_maker_quick_start AJAX action in addition to insufficient escaping and sanitization in all versions up to, and including, 5.1.8. This makes it possible for unauthenticated attackers to create quizzes and inject malicious web scripts into them that execute when a user visits the page.



Vulnerability Details for Poll Maker – Versus Polls, Anonymous Polls, Image Polls

Software Type Plugin
Software Slug poll-maker (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.1.9, or a newer patched version
Affected Version
  • <= 5.1.8
Patched Version
  • 5.1.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.