Predictive Search <= 1.2.2 - Missing Authorization

Missing Authorization
CVSS 6.5 (Medium)
Publicly Published May 15, 2023
Last Updated January 22, 2024


The Predictive Search plugin for WordPress is vulnerable to unauthorized disclosure of data due to a missing capability check on the 'get_exclude_options_ajax' function called via a wp_ajax and wp_ajax_nopriv hook in versions up to, and including, 1.2.2. This makes it possible for unauthenticated attackers to retrieve exclude options for search data.



Vulnerability Details for Predictive Search

Software Type Plugin
Software Slug predictive-search (view on
Patched? Yes
Remediation Update to version 1.2.3, or a newer patched version
Affected Version
  • <= 1.2.2
Patched Version
  • 1.2.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.