QuBotChat <= 1.1.5 - Unauthenticated Self-Based Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-2399
CVSS 4.7 (Medium)
Publicly Published May 9, 2023
Last Updated June 16, 2023
Researcher Rafael B.


The QuBotChat plugin for WordPress is vulnerable to Self-Based Cross-Site Scripting in versions up to, and including, 1.1.5 due to insufficient input sanitization and output escaping. This makes it possible for attackers to inject arbitrary web scripts in pages that will execute when a user accesses the injected page, however, this may only be successful if the attacker can trick the user into pasting a malicious payload into the chat.



1 affected software package

Software Type Plugin
Software Slug qubotchat (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.1.6, or a newer patched version
Affected Version
  • <= 1.1.5
Patched Version
  • 1.1.6

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.