Quiz And Survey Master <= 7.3.10 - Unauthenticated Stored Cross-Site Scripting

7.2
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-40698
CVSS 7.2 (High)
Publicly Published October 21, 2022
Last Updated January 22, 2024
Researcher Thura Moe Myint - Patchstack Alliance

Description

The Quiz And Survey Master plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 7.3.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. If the plugin setting "Require User Login" is disabled, this vulnerability can be exploited by unauthenticated attackers.

References

Share

1 affected software package

Software Type Plugin
Software Slug quiz-master-next (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.3.11, or a newer patched version
Affected Version
  • <= 7.3.10
Patched Version
  • 7.3.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation