RabbitLoader <= 2.19.13 - Missing Authorization via multiple AJAX actions

Missing Authorization
CVE CVE-2024-21751
CVSS 5.4 (Medium)
Publicly Published January 8, 2024
Last Updated January 22, 2024
Researcher Abdi Pranata


The RabbitLoader plugin for WordPress is vulnerable to unauthorized modification of data and loss of data due to a missing capability check on multiple AJAX functions in versions up to, and including, 2.19.13. This makes it possible for authenticated attackers, with subscriber-level access and above, to purge site cache or switch caching modes.



Vulnerability Details for RabbitLoader – Website Speed Optimization for improving Core Web Vital metrics with Cache, Image Optimization, and more

Software Type Plugin
Software Slug rabbit-loader (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.19.14, or a newer patched version
Affected Version
  • <= 2.19.13
Patched Version
  • 2.19.14

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.