Related Posts for WordPress <= 2.2.1 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-0592
CVSS 5.4 (Medium)
Publicly Published March 13, 2024
Last Updated March 13, 2024
Researcher Krzysztof Zając - CERT PL


The Related Posts for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.2.1. This is due to missing or incorrect nonce validation on the handle_create_link() function. This makes it possible for unauthenticated attackers to add related posts to other posts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This ultimately makes it possible for attackers to view draft and password protected posts.



Vulnerability Details for Related Posts for WordPress

Software Type Plugin
Software Slug related-posts-for-wp (view on
Patched? Yes
Remediation Update to version 2.2.2, or a newer patched version
Affected Version
  • <= 2.2.1
Patched Version
  • 2.2.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.