Remove Duplicate Posts <= 1.3.5 - Missing Authorization to Post Deletion

Missing Authorization
CVE CVE-2023-29237
CVSS 4.3 (Medium)
Publicly Published July 24, 2023
Last Updated March 25, 2024
Researcher Junsu Yeo


The Remove Duplicate Posts plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the rdp_ajax_process() and rdp_get_result() functions in versions up to, and including, 1.3.5. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete posts and retrieve duplicate post ids.



Vulnerability Details for Remove Duplicate Posts

Software Type Plugin
Software Slug remove-duplicate-posts (view on
Patched? Yes
Remediation Update to version 1.3.6, or a newer patched version
Affected Version
  • <= 1.3.5
Patched Version
  • 1.3.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.