WordPress Shortcodes Plugin — Shortcodes Ultimate <= 5.0.0 - Authenticated Remote Code Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2017-18580
CVSS 8.8 (High)
Publicly Published October 31, 2017
Last Updated January 25, 2023
Researcher Robert Mathews


The shortcodes-ultimate plugin before 5.0.1 for WordPress has remote code execution via a filter in a meta, post, or user shortcode.



1 affected software package

Software Type Plugin
Software Slug shortcodes-ultimate (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.0.1, or a newer patched version
Affected Version
  • < 5.0.1
Patched Version
  • 5.0.1

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.