Simple Job Board <= 2.10.8 - Missing Authorization to Unauthenticated Information Disclosure

Missing Authorization
CVE CVE-2024-0593
CVSS 5.3 (Medium)
Publicly Published February 20, 2024
Last Updated February 21, 2024
Researcher Krzysztof Zając - CERT PL


The Simple Job Board plugin for WordPress is vulnerable to unauthorized access of data| due to insufficient authorization checking on the fetch_quick_job() function in all versions up to, and including, 2.10.8. This makes it possible for unauthenticated attackers to fetch arbitrary posts, which can be password protected or private and contain sensitive information.



Vulnerability Details for Simple Job Board

Software Type Plugin
Software Slug simple-job-board (view on
Patched? Yes
Remediation Update to version 2.11.0, or a newer patched version
Affected Version
  • <= 2.10.8
Patched Version
  • 2.11.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.