Spectra Pro <= 1.1.5 - Authenticated (Author+) Privilege Escalation

Improper Privilege Management
CVE CVE-2024-3828
CVSS 8.8 (High)
Publicly Published May 9, 2024
Last Updated May 10, 2024
Researcher Ngô Thiên An (ancorn_) - VNPT-VCI


The Spectra Pro plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.1.5. This is due to the plugin allowing lower-privileged users to create registration forms and set the default role to administrator This makes it possible for authenticated attackers, with author-level access and above, to create administrator-level accounts.



Vulnerability Details for Spectra Pro

Software Type Plugin
Software Slug spectra-pro
Patched? Yes
Remediation Update to version 1.1.6, or a newer patched version
Affected Version
  • <= 1.1.5
Patched Version
  • 1.1.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.