Spiffy Calendar <= 4.9.3 - Reflected Cross-Site Scripting via page parameter

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-32122
CVSS 4.7 (Medium)
Publicly Published May 3, 2023
Last Updated May 8, 2023
Researcher LEE SE HYOUNG


The Spiffy Calendar plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘page’ parameter in versions up to, and including, 4.9.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Note that exploitation may not be practical because it relies on attribute-based cross-site scripting in a hidden field.



Vulnerability Details for Spiffy Calendar

Software Type Plugin
Software Slug spiffy-calendar (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.9.4, or a newer patched version
Affected Version
  • < 4.9.4
Patched Version
  • 4.9.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.