Spiffy Calendar <= 4.9.8 - Insufficient Authorization

Incorrect Authorization
CVE CVE-2024-0855
CVSS 4.3 (Medium)
Publicly Published January 12, 2024
Last Updated March 22, 2024
Researcher cyc707


The Spiffy Calendar plugin for WordPress is vulnerable to unauthorized modification of data due insufficient restrictions on the event_author parameter in all versions up to, and including, 4.9.8. This makes it possible for authenticated attackers, with contributor-level access and above, to make an event appear as though it was created by another user.



Vulnerability Details for Spiffy Calendar

Software Type Plugin
Software Slug spiffy-calendar (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.9.9, or a newer patched version
Affected Version
  • <= 4.9.8
Patched Version
  • 4.9.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.