SEO Plugin by Squirrly SEO <= 12.1.20 - Missing Authorization

Missing Authorization
CVE CVE-2022-44626
CVSS 6.3 (Medium)
Publicly Published March 17, 2023
Last Updated March 21, 2023
Researcher Rafie Muhammad - Patchstack


The SEO Plugin by Squirrly SEO plugin for WordPress is vulnerable to unauthorized access/modification or loss of data due to a missing capability check on AJAX action handlers in versions up to, and including, 12.1.20. This makes it possible for authenticated attackers with subscriber-level access, and above, to invoke those functions.

Wordfence blocked 3,913 attacks targeting this vulnerability in the past 24 hours.



1 affected software package

Software Type Plugin
Software Slug squirrly-seo (view on
Patched? Yes
Remediation Update to version 12.1.21, or a newer patched version
Affected Version
  • <= 12.1.20
Patched Version
  • 12.1.21

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.