StopBadBots <= 7.23 - Missing Authorization to Arbitrary Plugin Installation

Missing Authorization
CVE CVE-2022-3883
CVSS 6.5 (Medium)
Publicly Published November 18, 2022
Last Updated December 5, 2022
Researcher Lana Codes


The StopBadBots plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the stopbadbots_install_plugin() function in versions up to, and including, 3.04. This makes it possible for authenticated attackers with minimal permission, such as a subscriber, to install arbitrary plugins on the vulnerable site. This could be used to install additional vulnerable plugins that could aid in further compromise of the site.



1 affected software package

Software Type Plugin
Software Slug stopbadbots (view on
Patched? Yes
Remediation Update to version 7.24, or a newer patched version
Affected Version
  • <= 7.23
Patched Version
  • 7.24

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.