Survey Maker – Best WordPress Survey Plugin <= 3.1.3 - Unauthenticated Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-0038
CVSS 7.2 (High)
Publicly Published January 3, 2023
Last Updated January 31, 2023
Researcher Chloe Chamberland - Wordfence


The "Survey Maker – Best WordPress Survey Plugin" plugin for WordPress is vulnerable to Stored Cross-Site Scripting via survey answers in versions up to, and including, 3.1.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts when submitting quizzes that will execute whenever a user accesses the submissions page.



Vulnerability Details for Survey Maker – Customer Satisfaction Questionnaire, Chat Survey, Calculation Form, Payment Forms

Software Type Plugin
Software Slug survey-maker (view on
Patched? Yes
Remediation Update to version 3.1.4, or a newer patched version
Affected Version
  • <= 3.1.3
Patched Version
  • 3.1.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.