Themify – WooCommerce Product Filter <= 1.4.3 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-2262
CVSS 4.3 (Medium)
Publicly Published March 11, 2024
Last Updated April 24, 2024
Researcher Erwan LR - WPScan


The Themify – WooCommerce Product Filter plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4.3. This is due to missing or incorrect nonce validation on the wpf_search page. This makes it possible for unauthenticated attackers to delete arbitrary filters via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Themify – WooCommerce Product Filter

Software Type Plugin
Software Slug themify-wc-product-filter (view on
Patched? Yes
Remediation Update to version 1.4.4, or a newer patched version
Affected Version
  • <= 1.4.3
Patched Version
  • 1.4.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.