Tutor LMS <= 2.6.0 - Authenticated(Student+) HTML Injection via Q&A

Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
CVE CVE-2024-1128
CVSS 5.4 (Medium)
Publicly Published February 20, 2024
Last Updated February 20, 2024
Researcher drop


The Tutor LMS – eLearning and online course solution plugin for WordPress is vulnerable to HTML Injection in all versions up to, and including, 2.6.0. This is due to insufficient sanitization of HTML input in the Q&A functionality. This makes it possible for authenticated attackers, with Student access and above, to inject arbitrary HTML onto a site, though it does not allow Cross-Site Scripting



Vulnerability Details for Tutor LMS – eLearning and online course solution

Software Type Plugin
Software Slug tutor (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.1, or a newer patched version
Affected Version
  • <= 2.6.0
Patched Version
  • 2.6.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.