Tutor LMS – eLearning and online course solution <= 2.6.1 - Cross-Site Request Forgery to Plugin Deactivation and Data Erase

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-1503
CVSS 4.3 (Medium)
Publicly Published March 12, 2024
Last Updated March 12, 2024
Researcher Lucio Sá


The Tutor LMS – eLearning and online course solution plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.1. This is due to missing or incorrect nonce validation on the erase_tutor_data() function. This makes it possible for unauthenticated attackers to deactivate the plugin and erase all data via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This requires the "Erase upon uninstallation" option to be enabled.



Vulnerability Details for Tutor LMS – eLearning and online course solution

Software Type Plugin
Software Slug tutor (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.6.2, or a newer patched version
Affected Version
  • <= 2.6.1
Patched Version
  • 2.6.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.