Welcart e-Commerce <= 2.8.5 - Authenticated (Subscriber+) Information Disclosure and PHAR deserialization

Deserialization of Untrusted Data
CVE CVE-2022-4237
CVSS 6.5 (Medium)
Publicly Published December 5, 2022
Last Updated January 24, 2023
Researcher WPScanTeam


The Welcart e-Commerce plugin for WordPress is vulnerable to Information Disclosure due to missing capability checks on the wel_check_progress_ajax AJAX action in versions up to, and including, 2.8.5. This makes it possible for authenticated attackers, with subscriber-level privileges or higher, to read certain log files maintained by the plugin leading to information disclosure. While the log file names are known and are directly accessible via browser on a server that is configured to serve .txt and .log files, the vulnerability allows attackers to access log files on other sites sharing the same server and also provides the ability to read such log files even if direct access is forbidden. Furthermore, the plugin is vulnerable to deserialization of untrusted input via the 'progressfile ' parameter. This makes it possible for attackers to call files using a PHAR wrapper, granted they can trick a site administrator into performing an action such as clicking on a link, that will deserialize and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.



Vulnerability Details for Welcart e-Commerce

Software Type Plugin
Software Slug usc-e-shop (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.8.6, or a newer patched version
Affected Version
  • <= 2.8.5
Patched Version
  • 2.8.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.