WCFM Marketplace <= 3.4.11 - Missing Authorization

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2022-4935
CVSS 8.8 (High)
Publicly Published April 5, 2023
Last Updated April 5, 2023
Researcher Chloe Chamberland - Wordfence


The WCFM Marketplace plugin for WordPress is vulnerable to unauthorized modification and access of data in versions up to, and including, 3.4.11 due to missing capability checks on various AJAX actions. This makes it possible for authenticated attackers, with minimal permissions such as subscribers, to perform a wide variety of actions such as modifying shipping method details, modifying products, deleting arbitrary posts, and privilege escalation (via the wp_ajax_wcfm_vendor_store_online AJAX action).



1 affected software package

Software Type Plugin
Software Slug wc-multivendor-marketplace (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4.12, or a newer patched version
Affected Version
  • <= 3.4.11
Patched Version
  • 3.4.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.