MailerLite – WooCommerce integration <= 2.0.8 - Missing Authorization via Multiple Functions

Missing Authorization
CVE CVE-2023-52227
CVSS 4.3 (Medium)
Publicly Published January 8, 2024
Last Updated January 15, 2024
Researcher Abdi Pranata


The MailerLite – WooCommerce integration plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on multiple functions in versions up to, and including, 2.0.8. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform unauthorized actions.



Vulnerability Details for MailerLite – WooCommerce integration

Software Type Plugin
Software Slug woo-mailerlite (view on
Patched? Yes
Remediation Update to version 2.0.9, or a newer patched version
Affected Version
  • <= 2.0.8
Patched Version
  • 2.0.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.