Wholesale For WooCommerce <= 2.3.0 - Unauthenticated Arbitrary Post Deletion

Missing Authorization
CVE CVE-2024-31297
CVSS 5.8 (Medium)
Publicly Published April 5, 2024
Last Updated April 10, 2024
Researcher Dave Jong - Patchstack


The Wholesale For WooCommerce plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on a function in all versions up to, and including, 2.3.0. This makes it possible for unauthenticated attackers to delete arbitrary posts.



Vulnerability Details for Wholesale For WooCommerce

Software Type Plugin
Software Slug woocommerce-wholesale-pricing
Patched? Yes
Remediation Update to version 2.3.1, or a newer patched version
Affected Version
  • <= 2.3.0
Patched Version
  • 2.3.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.