WordPress WP-Advanced-Search <= 3.3.3 - Unauthenticated Database Export

Information Exposure
CVSS 8.6 (High)
Publicly Published March 5, 2020
Last Updated December 22, 2022
Researcher Florian Hauser


The WordPress WP-Advanced-Search plugin for WordPress is vulnerable to unauthenticated database export in versions up to, and including, 3.3.3 via the WP_Advanced_Search_Export() function which makes it possible for unauthenticated attackers to export a vulnerable site's entire database. This is due to the WP_Advanced_Search_Export() function being hooked via an admin_post_nopriv action that is available to all users.



Vulnerability Details for WordPress WP-Advanced-Search

Software Type Plugin
Software Slug wp-advanced-search (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.3.4, or a newer patched version
Affected Version
  • <= 3.3.3
Patched Version
  • 3.3.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.