WordPress Automatic Plugin <= 3.53.2 - Unauthenticated Arbitrary Options Update

Missing Authorization
CVE CVE-2021-4374
CVSS 9.1 (Critical)
Publicly Published September 6, 2021
Last Updated January 22, 2024
Researcher Jerome Bruandet - NinTechNet


The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the process_form.php file. This makes it possible for unauthenticated attackers to arbitrarily update the settings of a vulnerable site and ultimately compromise the entire site.



Vulnerability Details for WordPress Automatic Plugin

Software Type Plugin
Software Slug wp-automatic
Patched? Yes
Remediation Update to version 3.53.3, or a newer patched version
Affected Version
  • < 3.53.3
Patched Version
  • 3.53.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.