wpCentral <= 1.4.7 - Privilege Escalation

Improper Privilege Management
CVSS 8.8 (High)
Publicly Published January 24, 2020
Last Updated January 22, 2024
Researcher WebARX Security - WebARX Security


The wpCentral for WordPress is vulnerable to privilege escalation in versions up to, and including, 1.4.7 due to missing authorization checks and validation on the wpc_fetch_authkey() and my_wpc_signon() functions. This makes it possible for authenticated users, with low-level privileges such as a subscriber, to log in as a site administrator.



Vulnerability Details for wpCentral

Software Type Plugin
Software Slug wp-central (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.4.8, or a newer patched version
Affected Version
  • < 1.4.8
Patched Version
  • 1.4.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.