WP JobSearch <= 2.3.3 - Authentication Bypass

Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2023-6584
CVSS 9.8 (Critical)
Publicly Published November 24, 2023
Last Updated March 22, 2024
Researcher Marc-Alexandre Montpas


The JobSearch WP Job Board plugin for WordPress is vulnerable to authenticated bypass in all versions up to, and including, 2.3.3. This is due to the plugin not properly validating a users identity through the jobsearch_facebook_get_soc_login_url action. This makes it possible for unauthenticated attackers to log in as any user, including administrators, as long as they have access to the email address.



Vulnerability Details for JobSearch WP Job Board

Software Type Plugin
Software Slug wp-jobsearch
Patched? Yes
Remediation Update to version 2.3.4, or a newer patched version
Affected Version
  • <= 2.3.3
Patched Version
  • 2.3.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.