WP User Frontend <= 3.5.25 - SQL Injection & Reflected Cross-Site Scripting

8.8
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2021-25076
CVSS 8.8 (High)
Publicly Published December 27, 2021
Last Updated January 5, 2023
Researcher Krzysztof Zając - CERT PL

Description

The WP User Frontend WordPress plugin before 3.5.26 does not validate and escape the status parameter before using it in a SQL statement in the Subscribers dashboard, leading to an SQL injection. Due to the lack of sanitisation and escaping, this could also lead to Reflected Cross-Site Scripting

References

Share

1 affected software package

Software Type Plugin
Software Slug wp-user-frontend (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.5.26, or a newer patched version
Affected Version
  • <= 3.5.25
Patched Version
  • 3.5.26

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation