WP User Frontend <= 3.5.28 - Privilege Escalation

Improper Privilege Management
CVE CVE-2021-24649
CVSS 8.1 (High)
Publicly Published October 31, 2022
Last Updated January 22, 2024
Researcher AyeCode Ltd


The WP User Frontend plugin for WordPress is vulnerable to privilege escalation due to the default user role checking on the process_registration function in versions up to, and including, 3.5.28 which accepts user supplied input via the urhidden value. This makes it possible for attackers, under certain circumstances, to register as administrators. This requires the attacker have access to the AUTH_KEY and AUTH_SALT values from wp-config.php.



1 affected software package

Software Type Plugin
Software Slug wp-user-frontend (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.5.29, or a newer patched version
Affected Version
  • <= 3.5.28
Patched Version
  • 3.5.29

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.