WP User Frontend <= 3.6.5 - Authenticated (Author+) Privilege Escalation

Improper Privilege Management
CVE CVE-2023-47682
CVSS 8.8 (High)
Publicly Published November 9, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack


The WP User Frontend – Registration, User Profile, Membership, Content Restriction, User Directory, and Frontend Post Submission Plugin plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.6.5. This is due to the plugin not providing sufficient controls on the ability to supply a role on the registration form shortcode rendered via the registration_form function. This makes it possible for authenticated attackers, with author-level access and above, to add a registration form to a page with the role set to administrator and then subsequently use the form to register as an administrator.



1 affected software package

Software Type Plugin
Software Slug wp-user-frontend (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.6.6, or a newer patched version
Affected Version
  • <= 3.6.5
Patched Version
  • 3.6.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.