YARPP – Yet Another Related Posts Plugin < 4.2.5 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVSS 9.8 (Critical)
Publicly Published May 8, 2015
Last Updated January 29, 2023
Researcher Evex - Evex


The YARPP – Yet Another Related Posts Plugin for WordPress is vulnerable a Cross-Site Request Forgery which can lead to Remote Code Execution in versions up to, and including, 4.2.4 via the yarpp_options.php file. This allows unauthenticated attackers to execute code on the server if they can successfully trick an administrator into performing an action such as clicking on a link.



Vulnerability Details for YARPP – Yet Another Related Posts Plugin

Software Type Plugin
Software Slug yet-another-related-posts-plugin (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.2.5, or a newer patched version
Affected Version
  • < 4.2.5
Patched Version
  • 4.2.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.