Bricks <= 1.9.6 - Unauthenticated Remote Code Execution

9.8
Improper Control of Generation of Code ('Code Injection')
CVE CVE-2024-25600
CVSS 9.8 (Critical)
Publicly Published February 13, 2024
Last Updated February 19, 2024
Researcher Snicco

Description

The Bricks theme for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.9.6. This makes it possible for unauthenticated attackers to execute code on the server.

Wordfence blocked 979 attacks targeting this vulnerability in the past 24 hours.

References

Share

1 affected software package

Software Type Theme
Software Slug bricks
Patched? Yes
Remediation Update to version 1.9.6.1, or a newer patched version
Affected Version
  • <= 1.9.6
Patched Version
  • 1.9.6.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation